View Issue Details

IDProjectCategoryView StatusLast Update
0000116ascenddocumentationpublic2009-05-01 17:45
Reporterjohn 
Assigned Tojds 
PrioritynormalSeveritytextReproducibilityalways
Status resolvedResolutionwon't fix 
Product Version 
Target VersionFixed in Version 
Summary0000116: How to build using jam?
DescriptionI see the build_linux script in the 'jam' directory, but Fedora Core 4 doesn't have Jam installed by default.

What version of Jam should I use? There seem to be various different Jams: Jam/MR, FT Jam, boost-jam -- which is the right one?

Can we set up a page on the wiki about this?

Jam should work find cross-platform, right? Or is this going to be a windows-specific build configuration?
TagsNo tags attached.

Relationships

child of 0000169 resolvedjds Complete implementation of Jam build 

Activities

john

2005-10-29 04:08

administrator   ~0000016

Tried with boost-jam, didn't work. http://jaist.dl.sourceforge.net/sourceforge/boost/boost-jam-3.1.11-1.i386.rpm

jds

2005-10-31 02:38

manager   ~0000017

A TWiki page has been started: https://pse.cheme.cmu.edu/wiki/view/Project/Jam

john

2005-11-01 08:35

administrator   ~0000019

From jds:


I updated my jam stuff in the repository. I spent a few hours debugging the build, and finally got it building. It's not pretty yet, but its a start. It builds the base libs, FORTRAN libs, and tcltk98 executable. I'm using ftjam 2.3.5 on Mandrake 10.1. The fledgling test suite is not operational on Linux yet - you'll get SIGSEGV if you run it. Something for me to work on this week.

jam would potentially replace gnumake, not configure. You'd still run configure to do all the system customization, but have configure generate Jamrules from Jamrules.in. My next task in this area, should I choose to accept it, is to integrate the Jamrules.in files with configure so you don't have to manually set options. Whether I do this will probably depend on whether we think jam is the best way to go for a cross-platform build system.

The MinGW MSYS system does have a autoconf implementation (Tcl/Tk also). I tried it before delving into jam, but it's not compatible with the autoconf version 2.13 configure.in currently used in ASCEND. Do you think that's what your correspondent was talking about, or is this an independent port? Art (mostly) and Ben have been toying with an upgrade to autoconf 2.5 - I was waiting to see where this goes before going wading in ASCEND's formidable configure.in.

Let me know how you make out with the jam build. Work through the jam subdirectories of base, blas, linpack, lsod, and tclck98, running 'jam -f ../../jam/Jambase' in each one. If you have questions or want to discuss anything, let me know or add it to the wiki.

john

2005-12-20 05:36

administrator   ~0000107

Ben writes:

fyi, my fc4 box has /usr/bin/jam from an rpm that was probably on the cd ISOs:
jam-2.5-2.fc4
Jam 2.5. OS=LINUX. Copyright 1993-2002 Christopher Seiwald.

john

2005-12-20 05:38

administrator   ~0000108

Hi Ben,

I found this version of Jam, it's perforce jam from Fedora Extras.

The freetype jam webpage says that ftjam supports building on more different platforms, but since Jerry is bundling his own Jambase, perhaps this doesn't matter.

JP

john

2009-05-01 17:45

administrator   ~0000504

not using jam any more

Issue History

Date Modified Username Field Change
2005-10-29 03:47 john New Issue
2005-10-29 03:47 john Status new => assigned
2005-10-29 03:47 john Assigned To => jds
2005-10-29 04:08 john Note Added: 0000016
2005-10-31 02:38 jds Note Added: 0000017
2005-11-01 08:35 john Note Added: 0000019
2005-12-20 02:40 john Relationship added child of 0000169
2005-12-20 05:36 john Note Added: 0000107
2005-12-20 05:38 john Note Added: 0000108
2006-02-07 13:19 john Target release => 1.0
2006-02-07 13:24 john Target release 1.0 => 0.9.6
2006-05-10 02:39 john Target release 0.9.6 => 1.0
2009-05-01 17:45 john Note Added: 0000504
2009-05-01 17:45 john Status assigned => resolved
2009-05-01 17:45 john Resolution open => won't fix