View Issue Details

IDProjectCategoryView StatusLast Update
0000145ascendcompilerpublic2008-02-10 13:02
Reporterjohn 
Assigned Tojohn 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.9.6 
Summary0000145: external statements and DYNAMIC_PACKAGES not working
DescriptionI have mentioned this issue on the mailing list and wiki (see [[ExternalLibraries]]). I will annotate further discoveries here.

JP
TagsNo tags attached.

Relationships

related to 0000247 closedjohn DYNAMIC_PACKAGES doesn't work on MinGW or Windows 
has duplicate 0000144 closedjohn External procedures are broken? 

Activities

john

2005-11-29 07:51

administrator   ~0000049

In instantiate.c, the following is noted at line ~7640 (phew!):

/* BUG!: CheckStatement and New flavors of same ignore the
   type EXT. We never use external relations inside a loop?!
   well, ok, maybe they are always hidden as models */

john

2005-11-29 07:56

administrator   ~0000050

See also extfunc.c and packages.c

john

2005-11-30 03:09

administrator   ~0000054

Kirk says:

Do a search on CreateExtern. I think that we dumped using Statements and instead created ExternalFunc (see ascend.y and extfunc.c) . Also grep on CreateBlackBoxRelation.

john

2006-03-15 08:13

administrator   ~0000300

It's CreateEXTERN. This function currently creates a 'struct Statement *' of type 'EXT'.

Nothing further gets done with it after that though, apparently. So maybe doing something nifty with a 'struct ExternalFunc' could be a good idea here?

What is 'g_ExtVariablesTable' and does it get used somewhere?

I don't see calls to 'CreateBlackBoxRelation' anywhere except
in the function 'AddExtArrayChildren', which is only called from
'ExecuteBlackBoxEXT' which is in turn only called from 'ExecuteEXT',
which never seems to get called at all, because of something that seems
to be missing from 'DoExternal', possibly.

john

2006-03-15 08:13

administrator   ~0000301

Last edited: 2006-03-15 08:17

DYNAMIC_PACKAGES are working on Linux; I have a linking problem to overcome in Windows still.

See also
http://article.gmane.org/gmane.comp.gnu.mingw.user/18727
http://lists.gnu.org/archive/html/libtool/2006-03/msg00013.html

john

2006-03-15 16:29

administrator   ~0000303

A libtool developer recommended that I try:
http://edll.sourceforge.net/

john

2006-03-15 16:35

administrator   ~0000304

splitting out this task into the separate parts.

Issue History

Date Modified Username Field Change
2005-11-29 07:50 john New Issue
2005-11-29 07:51 john Note Added: 0000049
2005-11-29 07:55 john Relationship added has duplicate 0000144
2005-11-29 07:56 john Note Added: 0000050
2005-11-30 03:09 john Note Added: 0000054
2006-02-07 13:19 john Target release => 1.0
2006-02-07 13:23 john Target release 1.0 => 0.9.6
2006-03-15 08:13 john Note Added: 0000300
2006-03-15 08:13 john Note Added: 0000301
2006-03-15 08:17 john Note Edited: 0000301
2006-03-15 08:28 john Status new => assigned
2006-03-15 08:28 john Assigned To => john
2006-03-15 16:29 john Note Added: 0000303
2006-03-15 16:34 john Relationship added related to 0000247
2006-03-15 16:35 john Status assigned => resolved
2006-03-15 16:35 john Resolution open => fixed
2006-03-15 16:35 john Note Added: 0000304
2006-06-22 07:36 john Status resolved => feedback
2006-06-22 07:48 john Status feedback => resolved
2006-06-22 07:48 john Fixed in Version => 0.9.6
2008-02-10 13:02 john Status resolved => closed