View Issue Details

IDProjectCategoryView StatusLast Update
0000175ascendsolverpublic2006-05-10 02:22
Reporterjohn 
Assigned Tojohn 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionwon't fix 
Product Version 
Target VersionFixed in Version 
Summary0000175: Solvers registration uses integer ID
DescriptionThe process for registering solvers is problematic in that it uses integers, and if the 'standard' solvers have not all been loaded and loaded in the correct order, then referring to solvers by their standard ID number causes problems.

For example, slv3 gives me this error:
 slv_solver_name called with unregistered index '3'

I have loaded solver slv3 but it's the only solver I have loaded, so it has ID=0.

There needs to be a better way of referring to solvers using a const char* or something like that.
TagsNo tags attached.

Relationships

duplicate of 0000178 closedben new system is initialised with solver=3 even if there are not 3 solvers registered 
child of 0000173 closedjohn Self-testing models 

Activities

john

2005-12-21 11:56

administrator   ~0000146

The real problem here is bug 0000178.

Issue History

Date Modified Username Field Change
2005-12-21 05:28 john New Issue
2005-12-21 11:42 john Relationship added child of 0000173
2005-12-21 11:56 john Relationship added duplicate of 0000178
2005-12-21 11:56 john Duplicate ID 0 => 178
2005-12-21 11:56 john Status new => resolved
2005-12-21 11:56 john Resolution open => won't fix
2005-12-21 11:56 john Assigned To => john
2005-12-21 11:56 john Note Added: 0000146
2006-02-07 13:19 john Target release => 1.0
2006-05-10 02:22 john Status resolved => closed