View Issue Details

IDProjectCategoryView StatusLast Update
0000176ascendbuild-systempublic2006-05-10 02:22
Reporterjohn 
Assigned Tojohn 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
Product Version 
Target VersionFixed in Version 
Summary0000176: Jam build system doesn't update correctly on change to ascParse.y
DescriptionWhen I make changes to ascParse.y, I get errors like

../generic/compiler/scanner.l: In function ?zz_lex?:
../generic/compiler/scanner.l:412: error: ?zz_lval? undeclared (first use in this function)
../generic/compiler/scanner.l:412: error: (Each undeclared identifier is reported only once
../generic/compiler/scanner.l:412: error: for each function it appears in.)

I think these may be related to dependencies not being set up correctly between scanner.l and ascParse.y, or something like that.
TagsNo tags attached.

Relationships

related to 0000170 closedjohn Error with YY_USE_CONST redefined in FC4 / GCC 4.0.2 
child of 0000169 resolvedjds Complete implementation of Jam build 

Activities

jds

2005-12-22 02:31

manager   ~0000149

I can't reproduce this. When I make changes to ascParse.y and scanner.l, the only warnings I get are:

Cc ..\jam\Debug\mingw\compiler\scanner.o
In file included from ../base/generic/utilities/ascConfig.h:418,
                 from ..\base\generic\compiler\scanner.l:36:
../base/generic/utilities/error.h:59:39: warning: ISO C does not permit named variadic macros
../base/generic/utilities/error.h:60:32: warning: ISO C does not permit named variadic macros
..\base\generic\compiler\scanner.c: In function `zz__init_buffer':
..\base\generic\compiler\scanner.c:3038: warning: implicit declaration of function `fileno'
..\base\generic\compiler\scanner.l: At top level:
..\base\generic\compiler\scanner.c:2792: warning: 'yyunput' defined but not used

john

2005-12-22 02:59

administrator   ~0000155

We'll open this one again if it reappears, but since you've reimplemented the Jam build, it's probably gone...

Issue History

Date Modified Username Field Change
2005-12-21 08:51 john New Issue
2005-12-21 08:51 john Relationship added child of 0000169
2005-12-21 08:52 john Relationship added related to 0000170
2005-12-22 02:31 jds Note Added: 0000149
2005-12-22 02:59 john Status new => resolved
2005-12-22 02:59 john Resolution open => unable to reproduce
2005-12-22 02:59 john Assigned To => john
2005-12-22 02:59 john Note Added: 0000155
2006-02-07 13:19 john Target release => 1.0
2006-05-10 02:22 john Status resolved => closed