View Issue Details

IDProjectCategoryView StatusLast Update
0000189ascendbuild-linuxpublic2009-05-01 17:40
Reporterjohn 
Assigned Tojds 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionwon't fix 
Product Version 
Target VersionFixed in Version 
Summary0000189: file install locations with 'jam install'
DescriptionIt seems that files are being placed in the following locations using 'jam install' after using 'reconfig'. This is equivalent to using ./configure with

[john@jdpipe autotools]$ autoconf && ./reconfig
LINUX CONFIGURATION
RUNNING CONFIGURE WITH
./configure --prefix=/home/john/ascroot --with-fortran=g77,/usr/lib/libf2c.a --enable-gcc --with-tcl=/usr/lib/libtcl8.3.so,/usr/include/tcl.h --with-tk=/usr/lib/libtk8.3.so,/usr/include/tk.h --with-wish=/usr/bin/wish --with-tktable=/usr/share/Tktable2.8/libTktable2.8.so

The --prefix option means that there should simply be directories 'bin', 'models', etc, under there. Not extra levels of heirarchy. Instead, I see:

Link ../jam/Debug/linux/ascend4
Chmod1 ../jam/Debug/linux/ascend4
MkDir1 /home/john/ascroot/Ascend4-0.9.5
MkDir1 /home/john/ascroot/Ascend4-0.9.5/ascend4
MkDir1 /home/john/ascroot/Ascend4-0.9.5/ascend4/bin
Install /home/john/ascroot/Ascend4-0.9.5/ascend4/bin/ascend4
Chmod1 /home/john/ascroot/Ascend4-0.9.5/ascend4/bin/ascend4
...
Install /home/john/ascroot/Ascend4-0.9.5/ascend4/Tk/bitmaps/grill
Install /home/john/ascroot/Ascend4-0.9.5/ascend4/Tk/bitmaps/h.xbm
Install /home/john/ascroot/Ascend4-0.9.5/ascend4/Tk/bitmaps/hourglass
...
Install /home/john/ascroot/Ascend4-0.9.5/ascend4/Tk/DisplayProc.tcl
Install /home/john/ascroot/Ascend4-0.9.5/ascend4/Tk/GlobalProc.tcl
...
Install /home/john/ascroot/Ascend4-0.9.5/ascend4/Tk/templates/AscMonoEntry1.t
Install /home/john/ascroot/Ascend4-0.9.5/ascend4/Tk/templates/AscMonoEntry2.t
Install /home/john/ascroot/Ascend4-0.9.5/ascend4/Tk/templates/AscMonoEntry4.t
TagsNo tags attached.

Relationships

child of 0000169 resolvedjds Complete implementation of Jam build 

Activities

john

2005-12-23 06:18

administrator   ~0000172

Fixed in changeset 178. Removed the extra directory levels, relying on --prefix config param. Will need tweaking on Windows.

jds

2005-12-23 18:04

manager   ~0000205

The jam install system is under construction. It is not surprising that it doesn't work properly. This should perhaps be more than a footnote in trunk/jam/ReadMe/txt. It's been used a bit under Windows but not worked out under Linux.

john

2005-12-23 18:24

administrator   ~0000206

Hi Jerry,

No worries, I just wanted to make sure I recorded all these things, since I had a bit of a session on all this stuff yesterday. It's looking good, I think. I've been able to build with Linux, and now install everything except the models.

john

2009-05-01 17:40

administrator   ~0000497

jam build no longer supported.

Issue History

Date Modified Username Field Change
2005-12-23 03:48 john New Issue
2005-12-23 03:48 john Relationship added child of 0000169
2005-12-23 06:18 john Note Added: 0000172
2005-12-23 06:19 john Assigned To => jds
2005-12-23 06:19 john Status new => feedback
2005-12-23 18:04 jds Note Added: 0000205
2005-12-23 18:24 john Note Added: 0000206
2006-02-07 13:18 john Target release => 1.0
2006-02-07 13:22 john Target release 1.0 => 0.9.6
2006-05-10 02:39 john Target release 0.9.6 => 1.0
2009-05-01 17:40 john Note Added: 0000497
2009-05-01 17:40 john Status feedback => resolved
2009-05-01 17:40 john Resolution open => won't fix