View Issue Details

IDProjectCategoryView StatusLast Update
0000190ascendsolverpublic2009-05-01 17:58
Reporterjohn 
Assigned Tojohn 
PrioritynormalSeverityminorReproducibilityalways
Status feedbackResolutionreopened 
Product Version 
Target Version1.0Fixed in Version 
Summary0000190: Autodetect of BLAS
DescriptionThe configuration file at present allows BLAS libraries to be manually specified. Most Fedora systems already include BLAS meaning that it should be possible to detect that and use it instead. I'm not yet familiar with how to code this stuff in configure.in, but it would be good if we could do this. I'm thinking that it might be feasible to eliminate the need for fortran compilation in cases where all the required prerequisites are present as static libraries already in the system...

Related to this is the issue of replacing LINPACK with LAPACK, which I will link to this bug.
TagsNo tags attached.

Relationships

related to 0000199 resolvedjohn Update autoconf macros: dl-unloading, BLAS detection, Tcl/Tk detection, value of NULL etc etc. 
related to 0000099 closedjohn Update to use LAPACK instead of LINPACK 

Activities

john

2005-12-23 04:16

administrator   ~0000169

Partial solution submitted as rev 176.
The ./reconfig script will use /usr/lib/libblas.a if it is present.

ben

2005-12-23 08:36

manager   ~0000180

If we are referring to the new autotools builds (2.59 based)
ACX_BLAS may be the way to go here. Don't try making the ac213 stuff
much more clever in this regard. as you can see from the
internals of the acx_blas implementation it's harder than
one might first imagine to get blas right.

john

2005-12-23 09:11

administrator   ~0000185

Reminder sent to: ben

As there were no files in the unixAC25x directory, I removed that directory from subversion. The new autotools directory at trunk/base/autotools is just a renamed unixAC213 directory, plus newer versions of files in autotools/config that I obtained from GNU autoconf 2.59.

I'm a definite autoconf newbie so if you could point out where I can see this ACX_BLAS thing, that would be great.

Probably there are lots of issues with the current autotools build and using autoconf-2.59 to run it. If you notice any problems, do let me know. But it works for me so far.

Cheers
JP

ben

2005-12-23 11:18

manager   ~0000196

google will point you at various archives containing acx_blas and other
autoconf macros. Finding the most recent update and packaging of
autoconf extensions is sometimes tricky. Often you end up
stealing them and putting them in your own config/ directory
used to build configure.
http://ac-archive.sourceforge.net/Installed_Packages
is one place.

ben

2005-12-23 11:22

manager   ~0000197

I expect most of the issues porting ascend up to ac2.59 will be
relatively simple, ascend being just c and fortran. a few ac macros
changed arguments.
 The most likely area of breakage would be around
tcl/tk i suspect if we've sucked in tickle's dynamic loading detection
to ascend's configure. There we probably want to shift to libtool anyway
for building, even if we continue to dlopen the old way and not use ltdl.

john

2005-12-23 12:29

administrator   ~0000201

Thanks for the link -- that will be really useful.

Cheers
JP

Issue History

Date Modified Username Field Change
2005-12-23 04:12 john New Issue
2005-12-23 04:13 john Relationship added related to 0000099
2005-12-23 04:16 john Status new => resolved
2005-12-23 04:16 john Resolution open => suspended
2005-12-23 04:16 john Assigned To => john
2005-12-23 04:16 john Note Added: 0000169
2005-12-23 08:36 ben Note Added: 0000180
2005-12-23 09:11 john Note Added: 0000185
2005-12-23 11:18 ben Status resolved => feedback
2005-12-23 11:18 ben Resolution suspended => reopened
2005-12-23 11:18 ben Note Added: 0000196
2005-12-23 11:22 ben Note Added: 0000197
2005-12-23 12:29 john Note Added: 0000201
2006-01-04 13:07 john Relationship added related to 0000199
2006-02-07 13:17 john Target release => 1.0
2006-02-07 13:22 john Target release 1.0 => 0.9.6
2006-05-10 03:51 john Target release 0.9.6 => 1.0
2009-05-01 16:53 john Target Version => 0.9.7
2009-05-01 17:58 john Target Version 0.9.7 => 1.0