View Issue Details

IDProjectCategoryView StatusLast Update
0000245ascendpackagespublic2008-02-10 13:03
Reporterjohn 
Assigned Tojohn 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.9.6 
Summary0000245: No provision for external packages nested in directories
DescriptionThe syntax for external libraries makes no provision for external libraries nested within subdirectories of the ASCENDLIBRARY search path.

For example, I would like to

IMPORT registerfn FROM johnpye/extfn/extfntest;

but that is a syntax error (the '/', I think). Note that the above would require some cross-platform smarts for directory separator, library suffix and prefix, etc
TagsNo tags attached.

Relationships

Activities

john

2006-05-10 01:26

administrator   ~0000321

Fixed at around changeset 622.

john

2006-05-10 01:27

administrator   ~0000322

Fixed at around changeset 622.

john

2006-05-17 00:56

administrator   ~0000342

This seems to be working OK now.

Issue History

Date Modified Username Field Change
2006-03-11 12:11 john New Issue
2006-03-11 12:11 john Target release => 0.9.6
2006-05-10 01:26 john Note Added: 0000321
2006-05-10 01:27 john Note Added: 0000322
2006-05-17 00:56 john Status new => assigned
2006-05-17 00:56 john Assigned To => john
2006-05-17 00:56 john Status assigned => resolved
2006-05-17 00:56 john Resolution open => fixed
2006-05-17 00:56 john Note Added: 0000342
2006-06-22 07:27 john Fixed in Version => 0.9.6
2008-02-10 13:03 john Status resolved => closed