View Issue Details

IDProjectCategoryView StatusLast Update
0000263ascendpygtk guipublic2008-02-10 13:03
Reporterjohn 
Assigned Tojohn 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.9.6 
Summary0000263: segfault on mouseover of incidence matrix
DescriptionIn changeset 686, with the PyGTK interface, open the file models/johnpye/radialheatloss.a4c. Hit solve, then view the incidence matrix. Mouse-over the graph. You get spew into the console, and ASCEND crashes.
TagsNo tags attached.

Relationships

related to 0000237 closedjohn Graphical components of PyGTK GUI crash under windows 

Activities

john

2006-05-26 14:21

administrator   ~0000357

In the console I get the text 'rel:' just before the crash. Looks like it might not be a pure GUI issue, somehow.

john

2006-06-15 09:43

administrator   ~0000372

This looks like windows-only, as well.

john

2006-06-21 14:43

administrator   ~0000374

Reproduced this on ubuntu 6.06 with matplotlib 0.97.3, numarray.

john

2006-06-22 01:33

administrator   ~0000375

Fixed in changeset 816. Not yet tested in Windows.

Issue History

Date Modified Username Field Change
2006-05-18 02:55 john New Issue
2006-05-18 02:55 john Status new => assigned
2006-05-18 02:55 john Assigned To => john
2006-05-18 02:55 john Target release => 0.9.6
2006-05-26 14:20 john Relationship added related to 0000237
2006-05-26 14:21 john Note Added: 0000357
2006-06-15 09:43 john Note Added: 0000372
2006-06-21 14:43 john Note Added: 0000374
2006-06-22 01:33 john Status assigned => resolved
2006-06-22 01:33 john Resolution open => fixed
2006-06-22 01:33 john Note Added: 0000375
2006-06-22 07:15 john Fixed in Version => 0.9.6
2008-02-10 13:03 john Status resolved => closed