View Issue Details

IDProjectCategoryView StatusLast Update
0000276ascendpygtk guipublic2010-04-09 15:59
Reporterjohn 
Assigned Tojohn 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version0.9.5.116 
Target Version0.9.8Fixed in Version0.9.8 
Summary0000276: 'view clique' seems not to work in PyGTK GUI
DescriptionTrying with the attached teste_clique.a4c, the 'view clique' command seems to fail, only shows the current member of the clique and not others.

Tested with both PyGTK and Tcl/Tk GUIs. Seems to be that we're using the 'NextCliqueMember' function incorrectly, or the model is not in the correct state when this function is being called, or something.
TagsNo tags attached.

Relationships

Activities

john

2010-03-22 12:18

administrator   ~0000584

This one should be easy to work out. See [[ARE_THE_SAME]] for example of syntax that should result in clique member list being generated.

john

2010-04-08 16:51

administrator   ~0000630

Last edited: 2010-04-08 16:52

From André FS:

I tried to write
one model to verify the bug (attached to this bug). If I understand it correctly,
in the GUI, when I right-click one of the variables which is in
ARE_THE_SAME statement (a1, for example), in "Properties", then
"Clique...", only "a1" is in the list, but "b1" should be there too.
Following is the traceback of my investigation about the bug:

* pygtk/properties.py, line 187: method getClique from model element
(variable) instance should return the list of instances in the same
Clique;
* model element 'instance' object comes from C++, by swig, then I
checked 'pygtk/instance.cpp', line 773. I was thinking the list could
be not completly pushed into the list returned by 'getClique'. I was
wrong. In fact, just one element is returned;
* Then I tried to understand the construction of list of Clique in
compiler code, but I wasn't successfull. I'm thinking that's because
there is no 'refines' treatment in merging cliques as commented in
'compiler/mergeinst.c', line 557;

2010-04-08 17:17

 

teste_clique.a4c (389 bytes)

john

2010-04-08 17:18

administrator   ~0000631

Can't see why this is failing. Looks as those when the GUI is attempting to traverse the clique the 'alike_ptr' values are not set.

john

2010-04-09 14:43

administrator   ~0000633

Understood the problem know. Misunderstanding about the term 'clique'. Clique refers to the set of instances related by [[ARE_ALIKE]] statements. What I was expecting here was the list of variable names that are [[ALIASES]] of each other. This is done not by the NextCliqueMember function but instead by using the WriteAliases function, or similar.

We need to *add* an extra button to display aliases for a particular variable.

Issue History

Date Modified Username Field Change
2006-07-15 04:26 john New Issue
2006-07-15 04:26 john Status new => assigned
2006-07-15 04:26 john Assigned To => john
2006-07-15 04:26 john Target release => 0.9.6
2009-05-01 16:53 john Target Version => 0.9.7
2009-05-01 17:58 john Target Version 0.9.7 => 1.0
2009-05-01 18:07 john Target Version 1.0 => 0.9.7
2010-02-24 18:18 john Assigned To john =>
2010-02-24 18:18 john Status assigned => new
2010-03-22 12:18 john Note Added: 0000584
2010-03-25 16:58 john Product Version => 0.9.5.116
2010-03-25 16:58 john Target Version 0.9.7 => 0.9.8
2010-04-08 16:51 john Note Added: 0000630
2010-04-08 16:51 john File Added: teste_clique.a4c
2010-04-08 16:52 john Note Edited: 0000630
2010-04-08 17:05 john Description Updated
2010-04-08 17:17 john File Deleted: teste_clique.a4c
2010-04-08 17:17 john File Added: teste_clique.a4c
2010-04-08 17:18 john Note Added: 0000631
2010-04-09 14:43 john Note Added: 0000633
2010-04-09 15:32 svn
2010-04-09 15:32 svn Status new => resolved
2010-04-09 15:32 svn Resolution open => fixed
2010-04-09 15:59 john Assigned To => john
2010-04-09 15:59 john Fixed in Version => 0.9.8