View Issue Details

IDProjectCategoryView StatusLast Update
0000345ascendinstaller-rpmpublic2009-06-03 12:02
Reporterjohn 
Assigned Tojohn 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version 
Target Version0.9.7Fixed in Version 
Summary0000345: rpmlint errors
Description/bin/sh -c rpmlint -i ~/rpmbuild/RPMS/i386/ascend-*.rpm
 in dir /home/buildbot/slaves/ascend/ascend-rpmbuild/build (timeout 1200 secs)
 watching logfiles {}
 argv: ['/bin/sh', '-c', 'rpmlint -i ~/rpmbuild/RPMS/i386/ascend-*.rpm']
 environment: {'SSH_ASKPASS': '/usr/libexec/openssh/gnome-ssh-askpass', 'LESSOPEN': '|/usr/bin/lesspipe.sh %s', 'SSH_CLIENT': '150.203.43.41 39570 22', 'CVS_RSH': 'ssh', 'LOGNAME': 'buildbot', 'USER': 'buildbot', 'INPUTRC': '/etc/inputrc', 'HOME': '/home/buildbot', 'PATH': '/usr/kerberos/bin:/usr/lib/ccache:/usr/local/bin:/bin:/usr/bin:/home/john/bin', 'DISPLAY': 'localhost:10.0', 'LANG': 'en_AU.UTF-8', 'TERM': 'xterm', 'SHELL': '/bin/bash', 'XAUTHORITY': '/home/buildbot/.xauthTnamgu', 'SHLVL': '2', 'G_BROKEN_FILENAMES': '1', 'HISTSIZE': '1000', 'EDITOR': 'vim', 'SVN_EDITOR': 'vim', '_': '/usr/bin/buildbot', 'LS_COLORS': 'no=00:fi=00:di=00;34:ln=00;36:pi=40;33:so=00;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:ex=00;32:*.cmd=00;32:*.exe=00;32:*.com=00;32:*.btm=00;32:*.bat=00;32:*.sh=00;32:*.csh=00;32:*.tar=00;31:*.tgz=00;31:*.arj=00;31:*.taz=00;31:*.lzh=00;31:*.zip=00;31:*.z=00;31:*.Z=00;31:*.gz=00;31:*.bz2=00;31:*.bz=00;31:*.tz=00;31:*.rpm=00;31:*.cpio=00;31:*.jpg=00;35:*.gif=00;35:*.bmp=00;35:*.xbm=00;35:*.xpm=00;35:*.png=00;35:*.tif=00;35:', 'SSH_TTY': '/dev/pts/0', 'OLDPWD': '/home/buildbot/slaves', 'HOSTNAME': 'stg-10.anu.edu.au', 'PWD': '/home/buildbot/slaves/ascend', 'MAIL': '/var/spool/mail/john', 'SSH_CONNECTION': '150.203.43.41 39570 150.203.42.22 22'}
ascend.i386: W: devel-file-in-non-devel-package /usr/share/ascend/models/johnpye/extpy/extpy.c
A development file (usually source code) is located in a non-devel
package. If you want to include source code in your package, be sure to
create a development package.

ascend.i386: W: devel-file-in-non-devel-package /usr/share/ascend/models/johnpye/datareader/dr.h
A development file (usually source code) is located in a non-devel
package. If you want to include source code in your package, be sure to
create a development package.

ascend.i386: W: devel-file-in-non-devel-package /usr/share/ascend/models/johnpye/dopri5/dopri5.c
A development file (usually source code) is located in a non-devel
package. If you want to include source code in your package, be sure to
create a development package.

ascend.i386: W: devel-file-in-non-devel-package /usr/share/ascend/models/johnpye/datareader/dr.c
A development file (usually source code) is located in a non-devel
package. If you want to include source code in your package, be sure to
create a development package.

ascend.i386: W: devel-file-in-non-devel-package /usr/share/ascend/models/johnpye/dopri5/dopri5.h
A development file (usually source code) is located in a non-devel
package. If you want to include source code in your package, be sure to
create a development package.

ascend.i386: W: devel-file-in-non-devel-package /usr/share/ascend/models/johnpye/datareader/texttable.c
A development file (usually source code) is located in a non-devel
package. If you want to include source code in your package, be sure to
create a development package.

ascend.i386: W: devel-file-in-non-devel-package /usr/share/ascend/models/johnpye/datareader/texttable.h
A development file (usually source code) is located in a non-devel
package. If you want to include source code in your package, be sure to
create a development package.

ascend.i386: E: non-executable-script /usr/share/ascend/models/johnpye/extfn/extfntest.py 0644
This text file contains a shebang or is located in a path dedicated for
executables, but lacks the executable bits and cannot thus be executed. If
the file is meant to be an executable script, add the executable bits,
otherwise remove the shebang or move the file elsewhere.

ascend.i386: W: devel-file-in-non-devel-package /usr/share/ascend/models/johnpye/datareader/datareader.c
A development file (usually source code) is located in a non-devel
package. If you want to include source code in your package, be sure to
create a development package.

ascend.i386: W: devel-file-in-non-devel-package /usr/share/ascend/models/johnpye/brent/brent.c
A development file (usually source code) is located in a non-devel
package. If you want to include source code in your package, be sure to
create a development package.

ascend.i386: W: hidden-file-or-dir /usr/share/ascend/tcltk/.xf-save-modules
The file or directory is hidden. You should see if this is normal,
and delete it from the package if not.

ascend.i386: E: non-executable-script /usr/share/ascend/tcltk/patchsrc.sh 0644
This text file contains a shebang or is located in a path dedicated for
executables, but lacks the executable bits and cannot thus be executed. If
the file is meant to be an executable script, add the executable bits,
otherwise remove the shebang or move the file elsewhere.

ascend.i386: W: devel-file-in-non-devel-package /usr/bin/ascend-config
A development file (usually source code) is located in a non-devel
package. If you want to include source code in your package, be sure to
create a development package.

ascend.i386: W: devel-file-in-non-devel-package /usr/share/ascend/models/test/blackbox/bboxtest.c
A development file (usually source code) is located in a non-devel
package. If you want to include source code in your package, be sure to
create a development package.

ascend.i386: W: devel-file-in-non-devel-package /usr/share/ascend/models/sensitivity/finitediff.c
A development file (usually source code) is located in a non-devel
package. If you want to include source code in your package, be sure to
create a development package.

ascend.i386: W: devel-file-in-non-devel-package /usr/share/ascend/models/johnpye/datareader/tmy.c
A development file (usually source code) is located in a non-devel
package. If you want to include source code in your package, be sure to
create a development package.

ascend.i386: W: devel-file-in-non-devel-package /usr/share/ascend/models/johnpye/extfn/extfntest.c
A development file (usually source code) is located in a non-devel
package. If you want to include source code in your package, be sure to
create a development package.

ascend.i386: W: devel-file-in-non-devel-package /usr/share/ascend/models/johnpye/datareader/tmy.h
A development file (usually source code) is located in a non-devel
package. If you want to include source code in your package, be sure to
create a development package.

ascend.i386: W: devel-file-in-non-devel-package /usr/share/ascend/models/johnpye/dopri5/asc_dopri5.c
A development file (usually source code) is located in a non-devel
package. If you want to include source code in your package, be sure to
create a development package.

ascend.i386: W: devel-file-in-non-devel-package /usr/share/ascend/models/sensitivity/sensitivity.c
A development file (usually source code) is located in a non-devel
package. If you want to include source code in your package, be sure to
create a development package.

ascend.i386: W: devel-file-in-non-devel-package /usr/share/ascend/models/johnpye/datareader/sun.h
A development file (usually source code) is located in a non-devel
package. If you want to include source code in your package, be sure to
create a development package.

ascend.i386: W: devel-file-in-non-devel-package /usr/share/ascend/models/johnpye/datareader/sun.c
A development file (usually source code) is located in a non-devel
package. If you want to include source code in your package, be sure to
create a development package.

ascend.i386: W: devel-file-in-non-devel-package /usr/share/ascend/models/sensitivity/solve.c
A development file (usually source code) is located in a non-devel
package. If you want to include source code in your package, be sure to
create a development package.

ascend.i386: W: tag-in-description Requires:
Something that looks like a tag was found in the package's description.
This may indicate a problem where the tag was not actually parsed as a tag
but just textual description content, thus being a no-op. Verify if this is
the case, and move the tag to a place in the specfile where %description
won't fool the specfile parser, and rebuild the package.

ascend.i386: W: tag-in-description Requires:
Something that looks like a tag was found in the package's description.
This may indicate a problem where the tag was not actually parsed as a tag
but just textual description content, thus being a no-op. Verify if this is
the case, and move the tag to a place in the specfile where %description
won't fool the specfile parser, and rebuild the package.

ascend.i386: W: tag-in-description Requires:
Something that looks like a tag was found in the package's description.
This may indicate a problem where the tag was not actually parsed as a tag
but just textual description content, thus being a no-op. Verify if this is
the case, and move the tag to a place in the specfile where %description
won't fool the specfile parser, and rebuild the package.

ascend.i386: W: tag-in-description Requires:
Something that looks like a tag was found in the package's description.
This may indicate a problem where the tag was not actually parsed as a tag
but just textual description content, thus being a no-op. Verify if this is
the case, and move the tag to a place in the specfile where %description
won't fool the specfile parser, and rebuild the package.

ascend.i386: W: tag-in-description Requires:
Something that looks like a tag was found in the package's description.
This may indicate a problem where the tag was not actually parsed as a tag
but just textual description content, thus being a no-op. Verify if this is
the case, and move the tag to a place in the specfile where %description
won't fool the specfile parser, and rebuild the package.

ascend.i386: W: tag-in-description Requires:
Something that looks like a tag was found in the package's description.
This may indicate a problem where the tag was not actually parsed as a tag
but just textual description content, thus being a no-op. Verify if this is
the case, and move the tag to a place in the specfile where %description
won't fool the specfile parser, and rebuild the package.

ascend.i386: W: tag-in-description Requires:
Something that looks like a tag was found in the package's description.
This may indicate a problem where the tag was not actually parsed as a tag
but just textual description content, thus being a no-op. Verify if this is
the case, and move the tag to a place in the specfile where %description
won't fool the specfile parser, and rebuild the package.

ascend.i386: W: tag-in-description Requires:
Something that looks like a tag was found in the package's description.
This may indicate a problem where the tag was not actually parsed as a tag
but just textual description content, thus being a no-op. Verify if this is
the case, and move the tag to a place in the specfile where %description
won't fool the specfile parser, and rebuild the package.

ascend.i386: W: tag-in-description Requires:
Something that looks like a tag was found in the package's description.
This may indicate a problem where the tag was not actually parsed as a tag
but just textual description content, thus being a no-op. Verify if this is
the case, and move the tag to a place in the specfile where %description
won't fool the specfile parser, and rebuild the package.

ascend.i386: W: tag-in-description Requires:
Something that looks like a tag was found in the package's description.
This may indicate a problem where the tag was not actually parsed as a tag
but just textual description content, thus being a no-op. Verify if this is
the case, and move the tag to a place in the specfile where %description
won't fool the specfile parser, and rebuild the package.

ascend.i386: W: tag-in-description Requires:
Something that looks like a tag was found in the package's description.
This may indicate a problem where the tag was not actually parsed as a tag
but just textual description content, thus being a no-op. Verify if this is
the case, and move the tag to a place in the specfile where %description
won't fool the specfile parser, and rebuild the package.

ascend.i386: W: tag-in-description Requires:
Something that looks like a tag was found in the package's description.
This may indicate a problem where the tag was not actually parsed as a tag
but just textual description content, thus being a no-op. Verify if this is
the case, and move the tag to a place in the specfile where %description
won't fool the specfile parser, and rebuild the package.

ascend.i386: W: tag-in-description Requires:
Something that looks like a tag was found in the package's description.
This may indicate a problem where the tag was not actually parsed as a tag
but just textual description content, thus being a no-op. Verify if this is
the case, and move the tag to a place in the specfile where %description
won't fool the specfile parser, and rebuild the package.

ascend.i386: W: tag-in-description Requires(post):
Something that looks like a tag was found in the package's description.
This may indicate a problem where the tag was not actually parsed as a tag
but just textual description content, thus being a no-op. Verify if this is
the case, and move the tag to a place in the specfile where %description
won't fool the specfile parser, and rebuild the package.

ascend.i386: W: tag-in-description Requires(postun):
Something that looks like a tag was found in the package's description.
This may indicate a problem where the tag was not actually parsed as a tag
but just textual description content, thus being a no-op. Verify if this is
the case, and move the tag to a place in the specfile where %description
won't fool the specfile parser, and rebuild the package.

ascend.i386: W: tag-in-description Provides:
Something that looks like a tag was found in the package's description.
This may indicate a problem where the tag was not actually parsed as a tag
but just textual description content, thus being a no-op. Verify if this is
the case, and move the tag to a place in the specfile where %description
won't fool the specfile parser, and rebuild the package.

ascend.i386: W: incoherent-version-in-changelog 0.9.5.114 0.9.5.114-0.1879.f7
The last entry in %changelog contains a version identifier that is not
coherent with the epoch:version-release tuple of the package.

ascend.i386: W: unstripped-binary-or-object /usr/lib/libascendtcl.so
ascend.i386: W: no-soname /usr/lib/libascendtcl.so
ascend.i386: W: unstripped-binary-or-object /usr/lib/libascend.so
ascend.i386: W: no-soname /usr/lib/libascend.so
ascend.i386: E: arch-dependent-file-in-usr-share /usr/share/ascend/solvers/libqrslv_ascend.so
This package installs an ELF binary in the /usr/share
 hierarchy, which is reserved for architecture-independent files.

ascend.i386: W: unstripped-binary-or-object /usr/share/ascend/solvers/libqrslv_ascend.so
ascend.i386: E: arch-dependent-file-in-usr-share /usr/share/ascend/solvers/libcmslv_ascend.so
This package installs an ELF binary in the /usr/share
 hierarchy, which is reserved for architecture-independent files.

ascend.i386: W: unstripped-binary-or-object /usr/share/ascend/solvers/libcmslv_ascend.so
ascend.i386: E: arch-dependent-file-in-usr-share /usr/share/ascend/solvers/liblrslv_ascend.so
This package installs an ELF binary in the /usr/share
 hierarchy, which is reserved for architecture-independent files.

ascend.i386: W: unstripped-binary-or-object /usr/share/ascend/solvers/liblrslv_ascend.so
ascend.i386: E: arch-dependent-file-in-usr-share /usr/share/ascend/solvers/liblsode_ascend.so
This package installs an ELF binary in the /usr/share
 hierarchy, which is reserved for architecture-independent files.

ascend.i386: W: unstripped-binary-or-object /usr/share/ascend/solvers/liblsode_ascend.so
ascend.i386: E: arch-dependent-file-in-usr-share /usr/share/ascend/solvers/libconopt_ascend.so
This package installs an ELF binary in the /usr/share
 hierarchy, which is reserved for architecture-independent files.

ascend.i386: W: unstripped-binary-or-object /usr/share/ascend/solvers/libconopt_ascend.so
ascend.i386: E: arch-dependent-file-in-usr-share /usr/share/ascend/solvers/libida_ascend.so
This package installs an ELF binary in the /usr/share
 hierarchy, which is reserved for architecture-independent files.

ascend.i386: W: unstripped-binary-or-object /usr/share/ascend/solvers/libida_ascend.so
ascend.i386: E: arch-dependent-file-in-usr-share /usr/share/ascend/_ascpy.so
This package installs an ELF binary in the /usr/share
 hierarchy, which is reserved for architecture-independent files.

ascend.i386: W: unstripped-binary-or-object /usr/share/ascend/_ascpy.so
ascend.i386: E: arch-dependent-file-in-usr-share /usr/share/ascend/models/johnpye/brent/libbrent_ascend.so
This package installs an ELF binary in the /usr/share
 hierarchy, which is reserved for architecture-independent files.

ascend.i386: W: unstripped-binary-or-object /usr/share/ascend/models/johnpye/brent/libbrent_ascend.so
ascend.i386: E: arch-dependent-file-in-usr-share /usr/share/ascend/models/johnpye/brent/brent.os
This package installs an ELF binary in the /usr/share
 hierarchy, which is reserved for architecture-independent files.

ascend.i386: W: unstripped-binary-or-object /usr/share/ascend/models/johnpye/brent/brent.os
ascend.i386: E: arch-dependent-file-in-usr-share /usr/share/ascend/models/johnpye/datareader/dr.os
This package installs an ELF binary in the /usr/share
 hierarchy, which is reserved for architecture-independent files.

ascend.i386: W: unstripped-binary-or-object /usr/share/ascend/models/johnpye/datareader/dr.os
ascend.i386: E: arch-dependent-file-in-usr-share /usr/share/ascend/models/johnpye/datareader/datareader.os
This package installs an ELF binary in the /usr/share
 hierarchy, which is reserved for architecture-independent files.

ascend.i386: W: unstripped-binary-or-object /usr/share/ascend/models/johnpye/datareader/datareader.os
ascend.i386: E: arch-dependent-file-in-usr-share /usr/share/ascend/models/johnpye/datareader/sun.os
This package installs an ELF binary in the /usr/share
 hierarchy, which is reserved for architecture-independent files.

ascend.i386: W: unstripped-binary-or-object /usr/share/ascend/models/johnpye/datareader/sun.os
ascend.i386: E: arch-dependent-file-in-usr-share /usr/share/ascend/models/johnpye/datareader/tmy.os
This package installs an ELF binary in the /usr/share
 hierarchy, which is reserved for architecture-independent files.

ascend.i386: W: unstripped-binary-or-object /usr/share/ascend/models/johnpye/datareader/tmy.os
ascend.i386: E: arch-dependent-file-in-usr-share /usr/share/ascend/models/johnpye/datareader/libdatareader_ascend.so
This package installs an ELF binary in the /usr/share
 hierarchy, which is reserved for architecture-independent files.

ascend.i386: W: unstripped-binary-or-object /usr/share/ascend/models/johnpye/datareader/libdatareader_ascend.so
ascend.i386: E: arch-dependent-file-in-usr-share /usr/share/ascend/models/johnpye/datareader/texttable.os
This package installs an ELF binary in the /usr/share
 hierarchy, which is reserved for architecture-independent files.

ascend.i386: W: unstripped-binary-or-object /usr/share/ascend/models/johnpye/datareader/texttable.os
ascend.i386: E: arch-dependent-file-in-usr-share /usr/share/ascend/models/johnpye/extfn/extfntest.os
This package installs an ELF binary in the /usr/share
 hierarchy, which is reserved for architecture-independent files.

ascend.i386: W: unstripped-binary-or-object /usr/share/ascend/models/johnpye/extfn/extfntest.os
ascend.i386: E: arch-dependent-file-in-usr-share /usr/share/ascend/models/johnpye/extfn/libextfntest_ascend.so
This package installs an ELF binary in the /usr/share
 hierarchy, which is reserved for architecture-independent files.

ascend.i386: W: unstripped-binary-or-object /usr/share/ascend/models/johnpye/extfn/libextfntest_ascend.so
ascend.i386: E: arch-dependent-file-in-usr-share /usr/share/ascend/models/johnpye/extpy/libextpy_ascend.so
This package installs an ELF binary in the /usr/share
 hierarchy, which is reserved for architecture-independent files.

ascend.i386: W: unstripped-binary-or-object /usr/share/ascend/models/johnpye/extpy/libextpy_ascend.so
ascend.i386: E: arch-dependent-file-in-usr-share /usr/share/ascend/models/johnpye/extpy/extpy.os
This package installs an ELF binary in the /usr/share
 hierarchy, which is reserved for architecture-independent files.

ascend.i386: W: unstripped-binary-or-object /usr/share/ascend/models/johnpye/extpy/extpy.os
ascend.i386: E: arch-dependent-file-in-usr-share /usr/share/ascend/models/johnpye/dopri5/libdopri5_ascend.so
This package installs an ELF binary in the /usr/share
 hierarchy, which is reserved for architecture-independent files.

ascend.i386: W: unstripped-binary-or-object /usr/share/ascend/models/johnpye/dopri5/libdopri5_ascend.so
ascend.i386: E: arch-dependent-file-in-usr-share /usr/share/ascend/models/johnpye/dopri5/asc_dopri5.os
This package installs an ELF binary in the /usr/share
 hierarchy, which is reserved for architecture-independent files.

ascend.i386: W: unstripped-binary-or-object /usr/share/ascend/models/johnpye/dopri5/asc_dopri5.os
ascend.i386: E: arch-dependent-file-in-usr-share /usr/share/ascend/models/johnpye/dopri5/dopri5.os
This package installs an ELF binary in the /usr/share
 hierarchy, which is reserved for architecture-independent files.

ascend.i386: W: unstripped-binary-or-object /usr/share/ascend/models/johnpye/dopri5/dopri5.os
ascend.i386: E: arch-dependent-file-in-usr-share /usr/share/ascend/models/sensitivity/solve.os
This package installs an ELF binary in the /usr/share
 hierarchy, which is reserved for architecture-independent files.

ascend.i386: W: unstripped-binary-or-object /usr/share/ascend/models/sensitivity/solve.os
ascend.i386: E: arch-dependent-file-in-usr-share /usr/share/ascend/models/sensitivity/libsensitivity_ascend.so
This package installs an ELF binary in the /usr/share
 hierarchy, which is reserved for architecture-independent files.

ascend.i386: W: unstripped-binary-or-object /usr/share/ascend/models/sensitivity/libsensitivity_ascend.so
ascend.i386: E: arch-dependent-file-in-usr-share /usr/share/ascend/models/sensitivity/libfinitediff_ascend.so
This package installs an ELF binary in the /usr/share
 hierarchy, which is reserved for architecture-independent files.

ascend.i386: W: unstripped-binary-or-object /usr/share/ascend/models/sensitivity/libfinitediff_ascend.so
ascend.i386: E: arch-dependent-file-in-usr-share /usr/share/ascend/models/sensitivity/sensitivity.os
This package installs an ELF binary in the /usr/share
 hierarchy, which is reserved for architecture-independent files.

ascend.i386: W: unstripped-binary-or-object /usr/share/ascend/models/sensitivity/sensitivity.os
ascend.i386: E: arch-dependent-file-in-usr-share /usr/share/ascend/models/sensitivity/finitediff.os
This package installs an ELF binary in the /usr/share
 hierarchy, which is reserved for architecture-independent files.

ascend.i386: W: unstripped-binary-or-object /usr/share/ascend/models/sensitivity/finitediff.os
ascend.i386: E: arch-dependent-file-in-usr-share /usr/share/ascend/models/sensitivity/libsolve_ascend.so
This package installs an ELF binary in the /usr/share
 hierarchy, which is reserved for architecture-independent files.

ascend.i386: W: unstripped-binary-or-object /usr/share/ascend/models/sensitivity/libsolve_ascend.so
ascend.i386: E: arch-dependent-file-in-usr-share /usr/share/ascend/models/test/blackbox/libbboxtest_ascend.so
This package installs an ELF binary in the /usr/share
 hierarchy, which is reserved for architecture-independent files.

ascend.i386: W: unstripped-binary-or-object /usr/share/ascend/models/test/blackbox/libbboxtest_ascend.so
ascend.i386: E: arch-dependent-file-in-usr-share /usr/share/ascend/models/test/blackbox/bboxtest.os
This package installs an ELF binary in the /usr/share
 hierarchy, which is reserved for architecture-independent files.

ascend.i386: W: unstripped-binary-or-object /usr/share/ascend/models/test/blackbox/bboxtest.os
ascend.i386: E: invalid-desktopfile /usr/share/applications/ascend4.desktop
.desktop file is not valid, check with desktop-file-validate

ascend.i386: E: invalid-desktopfile /usr/share/applications/ascend.desktop
.desktop file is not valid, check with desktop-file-validate

ascend-devel.i386: W: no-documentation
The package contains no documentation (README, doc, etc).
You have to include documentation files.

TagsNo tags attached.

Relationships

duplicate of 0000387 assignedjohn rpmlint reports many errors for fedora 9 package 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2007-11-15 19:05 john New Issue
2007-11-15 19:05 john Status new => assigned
2007-11-15 19:05 john Assigned To => john
2007-11-15 19:05 john Target release => 0.9.6
2009-05-01 16:53 john Target Version => 0.9.7
2009-05-01 17:58 john Target Version 0.9.7 => 1.0
2009-05-01 18:03 john Target Version 1.0 => 0.9.7
2009-06-03 12:02 john Relationship added duplicate of 0000387
2009-06-03 12:02 john Duplicate ID 0 => 387
2009-06-03 12:02 john Status assigned => resolved
2009-06-03 12:02 john Resolution open => duplicate