View Issue Details

IDProjectCategoryView StatusLast Update
0000403ascendpygtk guipublic2011-02-22 11:49
Reporterjohn 
Assigned Tojohn 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.6 
Target Version0.9.8Fixed in Version0.9.8 
Summary0000403: Error from SWIG with versions 1.3.39, 1.3.40
DescriptionThere is an error "lvalue required as unary ‘&’ operand" reported by G++ when attempting to compile pygtk/ascpy_wrap.cc with current trunk ASCEND on Fedora 11.

Same error now showing up in Ubuntu 10.04.
Additional InformationThe following steps build ASCEND on a clean Fedora 11 machine (I tested using the Live CD installed to a qemu/kvm virtual machine):

su
yum install scons subversion tk-devel flex bison gcc-gfortran gcc-c++ python-devel sundials-devel graphviz-devel swig
exit
svn co svn://ascend.cheme.cmu.edu/ascend/code/trunk ascend
cd ascend
scons

The build output finishes with the following error:

swig -o pygtk/ascpy_wrap.cc -python -c++ -O -I/usr/include/graphviz pygtk/ascpy.i
g++ -o pygtk/ascpy_wrap.os -c -fPIC -DHAVE_GCCVISIBILITY -I. -I/usr/include/python2.6 pygtk/ascpy_wrap.cc
pygtk/ascpy_wrap.cc: In function ‘PyObject* _wrap_Relation_getResidual(PyObject*, PyObject*)’:
pygtk/ascpy_wrap.cc:50451: error: lvalue required as unary ‘&’ operand
scons: *** [pygtk/ascpy_wrap.os] Error 1
scons: building terminated because of errors.
[root@squeak11 ascend]#
TagsNo tags attached.

Relationships

related to 0000402 feedbackjohn python(abi) = 2.5 is needed by package ascend-0.9.6-0.f9.i386 (/home/daacosta/Download/ascend-0.9.6-0.f9.i386.rpm) 

Activities

john

2009-11-28 13:46

administrator   ~0000570

Testing on Windows shows a problem with SWIG 1.3.39 and 1.3.40 but not with SWIG 1.3.36.

john

2010-02-24 18:13

administrator   ~0000571

Update: need to check status with Fedora 12 (and 13?)

john

2010-05-24 17:08

administrator   ~0000644

Fixed in changeset 2820.

john

2010-05-24 17:09

administrator   ~0000645

The issue was that the definition of 'class Relation' was different in solver.i and relation.h. Thanks to William Fulton from swig-user list.

Issue History

Date Modified Username Field Change
2009-06-16 19:42 john New Issue
2009-06-16 19:42 john Status new => assigned
2009-06-16 19:42 john Assigned To => john
2009-06-16 19:42 john Target release => 0.9.6
2009-06-16 19:43 john Relationship added related to 0000402
2009-06-16 20:00 john Steps to Reproduce Updated
2009-06-16 20:00 john Additional Information Updated
2009-06-16 20:01 john Steps to Reproduce Updated
2009-06-16 20:01 john Additional Information Updated
2009-06-16 20:06 john Additional Information Updated
2009-06-28 01:38 john Target Version => 0.9.7
2009-11-28 13:46 john Note Added: 0000570
2010-02-24 18:12 john Assigned To john =>
2010-02-24 18:12 john Status assigned => new
2010-02-24 18:13 john Note Added: 0000571
2010-05-02 17:57 john Summary Error from SWIG when compiling on Fedora 11 => Error from SWIG with versions 1.3.39, 1.3.40
2010-05-02 17:57 john Description Updated
2010-05-04 00:25 svn
2010-05-04 23:29 john Assigned To => john
2010-05-04 23:29 john Priority normal => high
2010-05-04 23:29 john Severity minor => major
2010-05-04 23:29 john Reproducibility have not tried => always
2010-05-04 23:29 john Status new => assigned
2010-05-04 23:29 john Target Version 0.9.7 => 0.9.8
2010-05-24 17:08 john Note Added: 0000644
2010-05-24 17:09 john Note Added: 0000645
2010-05-24 17:09 john Status assigned => resolved
2010-05-24 17:09 john Fixed in Version => 0.9.8
2010-05-24 17:09 john Resolution open => fixed
2011-02-22 11:49 john Status resolved => closed