View Issue Details

IDProjectCategoryView StatusLast Update
0000439ascendbuild-windowspublic2010-03-25 12:09
Reporterjohn 
Assigned Tojohn 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platformx86OSWindowsOS VersionXP
Product Version0.9.7 
Target Version0.9.8Fixed in Version0.9.8 
Summary0000439: Detection of G77 for building LSODE is still broken
DescriptionSomething's going wrong with the detection of the G77 fortran compiler on Windows (tested with 32bit XP).

Even though env['FORTRAN'] is set to 'g77', the building of LSODE is being attempted with 'gfortran'.

Could be a problem with 'SHFORTRAN' env var coming in to play with a different value?
TagsNo tags attached.

Relationships

Activities

john

2010-03-25 12:09

administrator   ~0000603

Seems to be fixed; checked on Windows XP, Ubuntu 9.10 and Mac OS X 10.5

Probably there will be some problems now with SCons <= 0.97, because of a bug in the detection of FORTRAN in that version.

Issue History

Date Modified Username Field Change
2010-03-25 11:00 john New Issue
2010-03-25 11:00 john Status new => assigned
2010-03-25 11:00 john Assigned To => john
2010-03-25 12:01 svn
2010-03-25 12:09 john Note Added: 0000603
2010-03-25 12:09 john Status assigned => resolved
2010-03-25 12:09 john Fixed in Version => 0.9.8
2010-03-25 12:09 john Resolution open => fixed