View Issue Details

IDProjectCategoryView StatusLast Update
0000448ascendbuild-windowspublic2010-05-25 10:18
Reporterjohn 
Assigned Tojohn 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version0.9.7 
Target Version0.9.8Fixed in Version0.9.8 
Summary0000448: windows build should not have 'installer' as default target
DescriptionThe failure of the 'installer' build target causes concerns for our new contributors. We need to chance the Windows default target to 'pygtk' or something like that, so that even in the absence of IPOPT, SUNDIALS, etc, the build will still show as succeeding.
TagsNo tags attached.

Relationships

Activities

john

2010-04-10 10:09

administrator   ~0000636

The point here is that the installer script (.nsi file) requires the presence of all the optional solvers in order to succeed, because it's trying to package them all into the completed installer.

It's possible to have a useful working copy of ASCEND without having those solvers, but on Windows, at present, you will always get a failed build because be default it always tries to go all the way through to building the installer in standard build with the command 'scons'.

john

2010-05-25 10:18

administrator   ~0000648

fixed in changeset 2816.

Issue History

Date Modified Username Field Change
2010-04-06 15:54 john New Issue
2010-04-06 15:54 john Status new => assigned
2010-04-06 15:54 john Assigned To => john
2010-04-06 15:54 john Target Version => 0.9.8
2010-04-10 10:09 john Note Added: 0000636
2010-05-25 10:18 john Note Added: 0000648
2010-05-25 10:18 john Status assigned => resolved
2010-05-25 10:18 john Fixed in Version => 0.9.8
2010-05-25 10:18 john Resolution open => fixed