View Issue Details

IDProjectCategoryView StatusLast Update
0000461ascendmac-supportpublic2011-04-04 14:33
ReporterArne 
Assigned Tojohn 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version0.9.7 
Target Version1.0Fixed in Version 
Summary0000461: On MAC OS X Ascend Ignores decimal places - 0.12345 becomes 0.00000
DescriptionOn Mac OS X 10.5.8 Ascend Ignores all decimal places - 0.12345 becomes 0.00000

This can lead to horrible "Division by zero" errors.

A way to work around this, is for example to define {PI} as 314159265e-8.
However all those provided models, like those in the "ben" folder contining all those UNIFAC factors, are virtually not usable as there are hundereds of numbers I would have to convert manually. Opening them causes about a hundred "Division by zero" errors.
Also using american units (feet, gallons...) does not work without converting all the factors in measures.a4l.

The problem only appears when I open a file with Ascend - if I just change a factor in the ascend user interface and use some 2.345 number, everything is fine.

It also did not work when I changed my regional settings to English (UK).

TagsNo tags attached.

Relationships

duplicate of 0000337 acknowledged Incompatibility with various number formats in Regional Settings 

Activities

Arne

2010-05-31 20:03

reporter   ~0000649

Ok - when I change the default number format in my system (System Preferences -> Interantional -> Formats) and change it from German to english, everything is fine... it's not a really big glitch but quite disturbing for new european users that don't know the problem.

Seems to be the same Bug like 0000337

john

2011-04-04 14:33

administrator   ~0000707

It's a duplicate, and in changeset 337, a warning (error) message has been added when the GUI starts up.

Issue History

Date Modified Username Field Change
2010-05-31 14:40 Arne New Issue
2010-05-31 20:03 Arne Note Added: 0000649
2010-07-11 18:15 john Relationship added related to 0000337
2011-02-22 17:34 john Target Version => 1.0
2011-04-04 14:33 john Note Added: 0000707
2011-04-04 14:33 john Relationship replaced duplicate of 0000337
2011-04-04 14:33 john Status new => resolved
2011-04-04 14:33 john Resolution open => fixed
2011-04-04 14:33 john Assigned To => john