View Issue Details

IDProjectCategoryView StatusLast Update
0000489ascendpygtk guipublic2011-03-01 11:47
Reporterjohn 
Assigned Tojohn 
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
PlatformLinuxOSUbuntuOS Version9.04
Product Version0.9.7 
Target Version0.9.8Fixed in Version0.9.8 
Summary0000489: error on right-click->"Select units" on wildcard units variable
DescriptionWhen testing with models/test/solvervar.a4c, right-click on either variable and hit "select units". An error results. Need to check for wildcard units variables before allowing the selection of units dialog.

Traceback (most recent call last):
  File "/home/john/ascend/pygtk/modelview.py", line 515, units_activate(self=<modelview.ModelView instance at 0x96bb9ec>, *args=(<gtk.ImageMenuItem object at 0x96be2d4 (GtkImageMenuItem at 0x9836668)>,))
        T = self.get_selected_type()
        _un = UnitsDialog(self.browser,T)
        _un.run()
  variables: {'self.browser': ('local', <gtkbrowser.Browser instance at 0x899c6ec>), 'UnitsDialog': ('global', <class unitsdialog.UnitsDialog at 0x96a9a7c>), '_un': (None, None), 'T': ('local', solver_var)}
  File "/home/john/ascend/pygtk/unitsdialog.py", line 28, __init__(self=<unitsdialog.UnitsDialog instance at 0x9673aac>, browser=<gtkbrowser.Browser instance at 0x899c6ec>, T=solver_var)
          self.browser.reporter.reportError("No dimensioned atom types available yet (have you loaded a model yet?)")
          raise RuntimeError("no units available")
  variables: {'RuntimeError': ('builtin', <type 'exceptions.RuntimeError'>)}
RuntimeError: no units available
TagsNo tags attached.

Relationships

related to 0000362 resolvedart PyGTK interface does not recognize solver_var as a variable type 

Activities

john

2011-03-01 11:47

administrator   ~0000683

fixed in changeset 3268.

the problem was that this model loads no dimension declarations, so there is nothing can the units dialog is able to display. changed to code so that no attempt to show the dialog is made, and the user receives an error message.

Issue History

Date Modified Username Field Change
2011-02-28 15:55 john New Issue
2011-02-28 15:55 john Status new => assigned
2011-02-28 15:55 john Assigned To => john
2011-02-28 15:56 john Relationship added related to 0000362
2011-03-01 11:47 john Note Added: 0000683
2011-03-01 11:47 john Status assigned => resolved
2011-03-01 11:47 john Fixed in Version => 0.9.8
2011-03-01 11:47 john Resolution open => fixed