View Issue Details

IDProjectCategoryView StatusLast Update
0000501ascendbuild-windowspublic2013-02-26 13:39
Reporterjohn 
Assigned Tojohn 
PrioritylowSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
PlatformWindowsOSWindowsOS Version7
Product Version0.9.7 
Target Version0.9.9Fixed in Version 
Summary0000501: pygtk/ascdev fails to load solvers under Windows 7
DescriptionSomething weird is happening in relation to ASCENDSOLVERS in the pygtk/ascdev script in Windows 7.

When limited numbers of solvers are added to WITH_SOLVERS (options.cache) then everything works as expect.

However, certain combinations of solvers in WITH_SOLVERS results in the solvers failing to behave correctly, often only IPOPT shows in the list in that case.

Somehow, these solver DLLs are crashing, or failing to load, or loading over the top of each other. It's not clear what it is. It's not particularly important as we don't use Windows as our primary development platform.

TagsNo tags attached.

Relationships

child of 0000524 resolvedjohn Add support for native MinGW-64 builds for Windows 7 

Activities

john

2011-11-11 11:30

administrator   ~0000781

move to 1.x release... won't fix for now.

john

2012-01-27 04:42

administrator   ~0000802

I believe this is happening because of ":" being used in path separators in some of the test code, eg setting ASCENDLIBRARY to "models:solvers/qrslv:solvers/ipopt:solvers/cmslv" etc.

To reproduce:

test/test solver_qrslv.bug513_simplify

...fails to load solvers on Windows.

Possible solutions:
* a function to translate a system-neutral path string into a native path
* put all out compiled solvers into a single directory?
* replace path literals with "path1" PATHSEP "path2" PATHSEP "path3", since (IIRC) ospath is capable of dealing with wrong / vs \ but not : vs ;.

Issue History

Date Modified Username Field Change
2011-03-28 11:52 john New Issue
2011-03-28 11:52 john Status new => assigned
2011-03-28 11:52 john Assigned To => john
2011-11-11 11:30 john Note Added: 0000781
2011-11-11 11:30 john Target Version 0.9.8 => 1.0
2012-01-27 04:42 john Note Added: 0000802
2012-01-27 07:17 svn
2012-01-27 07:21 svn
2012-02-03 11:04 svn
2012-02-03 11:04 svn Status assigned => resolved
2012-02-03 11:04 svn Resolution open => fixed
2012-02-03 11:04 john Relationship added child of 0000524
2013-02-26 13:39 john Target Version 1.0 => 0.9.9