View Issue Details

IDProjectCategoryView StatusLast Update
0000518ascendpygtk guipublic2011-08-17 22:26
Reporterjohn 
Assigned Toaakash 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformWindowsOSWindowsOS Version7
Product VersionSVN 
Target Version0.9.8Fixed in Version 
Summary0000518: fail to plot on Windows 7 after STUDY in PyGTK GUI
DescriptionWhen plotting using the new STUDY functionality in PyGTK in trunk r3765, I get an error. It makes it impossible to plot data in Windows 7, even though it seems to work fine with Ubuntu.

Steps To ReproduceBuild ASCEND installer as outlined in ASCEND wiki (or Aakash, use the installer that I have sent you just now).

1. download and expand the TMY file as described in models/johnpye/datareader/testtmy.a4c.
2. open the above model file
3. observe 't'
4. observe 'Gbnc'
5. run a study on t from 0d to 10d with 240 steps, and 'on_load' run at each step.
6. click 'plot' and select the default options

Error message is as attached.
TagsNo tags attached.

Relationships

Activities

john

2011-08-16 22:27

administrator  

snip-for-aakash.PNG (27,898 bytes)
snip-for-aakash.PNG (27,898 bytes)

john

2011-08-16 22:28

administrator   ~0000762

PS this STUDY functionality is rather slow. Perhaps it would be sped up by only doing a gtk 'refresh'/'redraw' every second so?

john

2011-08-16 23:02

administrator   ~0000764

hi aakash -- what do you think was the cause of this bug? why does checking for 'truth' not give the same as checking for non-empty string?

Issue History

Date Modified Username Field Change
2011-08-16 22:27 john New Issue
2011-08-16 22:27 john Status new => assigned
2011-08-16 22:27 john Assigned To => aakash
2011-08-16 22:27 john File Added: snip-for-aakash.PNG
2011-08-16 22:28 john Note Added: 0000762
2011-08-16 22:59 svn
2011-08-16 22:59 svn Status assigned => resolved
2011-08-16 22:59 svn Resolution open => fixed
2011-08-16 23:02 john Note Added: 0000764
2011-08-17 22:26 svn