View Issue Details

IDProjectCategoryView StatusLast Update
0000533ascendpygtk guipublic2012-04-04 01:47
Reporterjohn 
Assigned Tojohn 
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version0.9.8 
Target Version0.9.8Fixed in Version 
Summary0000533: Add support for 'recent files' list in PyGTK GUI
DescriptionThe 'File' menu should display a list of 5 or 8 recent files that have been opened in the ASCEND PyGTK GUI.

Also, if possible, recent files opened in the PyGTK GUI should be added to operating-system file lists, if that's not already happening, on Mac, Windows and Linux (Ubuntu 11.10 and Fedora 16 would be suitable for testing).
TagsNo tags attached.

Relationships

related to 0000538 resolvedjohn crashes in revsion 4059- gives the below error maybe due to new cahnges in trunk for recent files list. 

Activities

john

2012-03-30 03:04

administrator  

recentfiles.diff (295,950 bytes)

john

2012-03-30 03:05

administrator   ~0000834

"recentfiles.diff" file added, as provided by "Shaun" Liang He. Thanks Shaun!

shaun

2012-04-01 01:57

developer   ~0000836

oh, Sorry for didn't see your message here. :D

Issue History

Date Modified Username Field Change
2012-03-21 04:40 john New Issue
2012-03-30 03:04 john File Added: recentfiles.diff
2012-03-30 03:05 john Note Added: 0000834
2012-03-30 03:06 john Assigned To => john
2012-03-30 03:06 john Status new => assigned
2012-04-01 01:57 shaun Note Added: 0000836
2012-04-03 07:02 svn
2012-04-03 07:02 svn Status assigned => resolved
2012-04-03 07:02 svn Resolution open => fixed
2012-04-04 01:47 john Relationship added related to 0000538