View Issue Details

IDProjectCategoryView StatusLast Update
0000070ascendtcltk-guipublic2009-05-01 17:37
Reporterjohn 
Assigned Toben 
PrioritylowSeverityfeatureReproducibilityalways
Status resolvedResolutionwon't fix 
Product Version 
Target VersionFixed in Version 
Summary0000070: File.Exit always requires confirmation
DescriptionIt shouldn't be necessary to always confirm exit. If I have not solved anything, and I have no unmodified files, then I should be able to exit without confirming.
TagsNo tags attached.

Relationships

related to 0000069 closedjohn Can't quit from console 

Activities

ben

2006-06-05 16:33

manager   ~0000360

ascend is not an all-encompassing IDE. In particular, tcltk interface is not in the
code editor development business with a 1000 little file event listeners
tracking things such that the information needed to suppress the
exit query is available. If that functionality is needed, an eclipse-based
IDE for ascend should be developed, along with more modern parse tools,
namespace syntax, etc.

The hurried user may of course simply type 'exit' at the console prompt
and be spared the shutdown/cleanup.

This issue should be closed, but since I didn't open it, I'm just marking
it resolved. A new issue (provide Eclipse IDE) might be opened elsewhere.

john

2009-05-01 17:37

administrator   ~0000492

not fixing Tcl/Tk RFEs

Issue History

Date Modified Username Field Change
2005-10-08 02:19 john New Issue
2005-10-08 02:19 john Category compiler => gui
2005-11-05 08:01 john Relationship added related to 0000069
2006-02-07 13:16 john Target release => 0.9.6
2006-02-23 06:16 john Status new => assigned
2006-02-23 06:16 john Assigned To => ben
2006-06-05 16:33 ben Note Added: 0000360
2009-05-01 17:37 john Note Added: 0000492
2009-05-01 17:37 john Status assigned => resolved
2009-05-01 17:37 john Resolution open => won't fix