View Issue Details

IDProjectCategoryView StatusLast Update
0000087ascendcompilerpublic2011-01-09 22:07
Reporterjohn 
Assigned Tojohn 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version0.9.7Fixed in Version0.9.8 
Summary0000087: Invalid variables in a METHOD don't trip script execution
DescriptionI have a method


    METHOD specify;
        equilibrated.fixed := TRUE;
        str.P.fixed := TRUE;
        str.T.fixed := TRUE;
        std.f.fixed := TRUE;
    END specify;

Which attempts to set the variable std.f.fixed which does NOT exist.

When attempting to run this method from the script window, execution is NOT stopped when this error is encountered, which means that the script execution process is not suitable for debugging complex models.

Is the ON ERROR STOP thing possibly of use here?
TagsNo tags attached.

Relationships

related to 0000133 closedjohn Standardised error reporting 
related to 0000129 assignedjohn bintoken BinTokensCreate returns no status code 
has duplicate 0000212 resolvedjohn 'FIX' statement fails to notify when one of the variables in the list is not valid 
related to 0000371 resolvedjohn problem with error_reporter_tree_end if no output is made during it 

Activities

ben

2005-12-27 01:34

manager   ~0000212

There's quite a bit of machinery dedicated to method debugging
hanging about in the compiler directory. I'm sure
getting it interfaced to tcl so that I can provide interesting examples via
the current ascend was never completed.

ben

2005-12-27 01:38

manager   ~0000213

Incidentally, yes,
Library -> options -> ignore stop...
should be turned off. It seems to default to on.
The default is strange, but my recollection was the
majority of cmu users preferred it because it lets
them be more sloppy in their writing of test models
to have the errors printed but keep going with the
rest of the initialization and find other errors too.
Of course if the error messages don't get routed to
the appropriate file, you don't see anything.
The tickle interface has the ability to specify the error log file.

john

2009-05-01 17:53

administrator   ~0000507

Changing this to a compiler issue because similar problem also appears with PyGTK GUI.

john

2011-01-09 22:01

administrator   ~0000665

fixed as of changeset 3141, test case added to CUnit tests.

Issue History

Date Modified Username Field Change
2005-10-11 07:48 john New Issue
2005-11-15 05:14 john Relationship added related to 0000133
2005-12-24 05:06 john Relationship added related to 0000129
2005-12-27 01:34 ben Note Added: 0000212
2005-12-27 01:38 ben Note Added: 0000213
2008-02-10 17:59 john Status new => assigned
2008-02-10 17:59 john Assigned To => john
2009-05-01 16:52 john Target Version => 0.9.7
2009-05-01 17:53 john Note Added: 0000507
2009-05-01 17:53 john Category tcltk-gui => compiler
2009-05-01 17:58 john Target Version 0.9.7 => 1.0
2009-05-01 18:07 john Target Version 1.0 => 0.9.7
2009-05-26 18:00 john Relationship added has duplicate 0000212
2011-01-09 22:01 john Note Added: 0000665
2011-01-09 22:06 john Status assigned => resolved
2011-01-09 22:06 john Resolution open => fixed
2011-01-09 22:07 john Fixed in Version => 0.9.8
2011-01-10 23:31 john Relationship added related to 0000371