View Issue Details

IDProjectCategoryView StatusLast Update
0000120ascendcompilerpublic2008-02-10 13:05
Reporterjohn 
Assigned Tojohn 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionwon't fix 
Product Version 
Target VersionFixed in Version 
Summary0000120: Unhelpful error message when ASCENDLIBRARY env var missing
DescriptionThe ascend executable requires the ASCENDLIBRARY environment variable, and if it's not present, then (while running ASCEND from python) I get strange error messages: In this case I get a ASCEND error -3 ('memory error') from the 'OpenModule' function whenever ASCENDLIBRARY env var is not there.

A clear error message should be provided in the case of any expected-but-not-found environment variables.

Even better, it should be possible to hard-wire default values to be used in place of missing environment variables.


TagsNo tags attached.

Relationships

duplicate of 0000121 closedjohn Default environment variables should be set in base/generic, not tcltk98/generic 

Activities

john

2005-11-02 11:42

administrator   ~0000023

Regarding default environment variables, this has been implemented via tcltk98/generic/Driver.c, in the Tcl-based interface files.

TODO: move this code to the base/generic section for any environment variables used by the base/generic code.

Issue History

Date Modified Username Field Change
2005-11-02 09:37 john New Issue
2005-11-02 09:40 john Summary ASCENDLIBRARY environment variable => Unhelpful error message when ASCENDLIBRARY env var missing
2005-11-02 11:42 john Note Added: 0000023
2005-11-02 11:46 john Relationship added duplicate of 0000121
2005-11-02 11:46 john Duplicate ID 0 => 121
2005-11-02 11:46 john Status new => resolved
2005-11-02 11:46 john Resolution open => won't fix
2005-11-02 11:46 john Assigned To => john
2006-02-07 13:19 john Target release => 1.0
2008-02-10 13:05 john Status resolved => closed