View Issue Details

IDProjectCategoryView StatusLast Update
0000126ascendgeneralpublic2006-06-22 07:30
Reporterjohn 
Assigned Tojohn 
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionwon't fix 
Product Version 
Target VersionFixed in Version 
Summary0000126: Switch to libtool / ltdl for dynamic loading
DescriptionSwitching to libtool's ltdl might reduce the size of the codebase since I think that it provides essentially all of the functionality currently implemented at ascDynaLoad.c

http://www.gnu.org/software/libtool/manual.html#Libltdl-interface
http://cholm.home.cern.ch/cholm/misc/ltmm/ltdl_8h.html
Additional InformationNote also that the code currently shown in ascDynaLoad is NOT compatible with GPL: ASCEND can not be used by or distributed to users other than those with educational, research, or non-profit purposes in mind.

TagsNo tags attached.

Relationships

related to 0000068 closedjohn Autogenerated C code fails to compile, problems with btprolog.h ? 
related to 0000129 assignedjohn bintoken BinTokensCreate returns no status code 
related to 0000198 closedjohn bintoken: dynamic unloading not enabled on linux 
related to 0000199 resolvedjohn Update autoconf macros: dl-unloading, BLAS detection, Tcl/Tk detection, value of NULL etc etc. 

Activities

john

2005-11-05 10:54

administrator   ~0000031

http://www.gnu.org/software/libtool/manual.html#Distributing-libltdl

john

2005-11-29 07:57

administrator   ~0000051

Ben comments that there have been big problems with backward compatibility in libtool in the past, and that therefore it would need to be distributed with ASCEND for this approach to begin to be acceptable.

john

2006-01-04 10:15

administrator   ~0000219

I removed the Ultrix and OSF stuff from ascDynaLoad.c in changeset 194. This makes the ascDynaLoad file GPL compliant again, I think.

john

2006-05-10 02:29

administrator   ~0000324

The non-GPL code was removed from ascDynaload.c and also code for dead OSes was removed, so this file no longer has the bloat that it used to. Also, libtool doesn't really play with non-POSIX compilers eg MSVC++ so with SCons now in place this task doesn't seem necessary any more.

john

2006-06-22 07:30

administrator   ~0000379

Closed this since we don't ever plan to fix this now.

Issue History

Date Modified Username Field Change
2005-11-05 05:33 john New Issue
2005-11-05 05:34 john Relationship added related to 0000068
2005-11-05 10:12 john Description Updated
2005-11-05 10:12 john Additional Information Updated
2005-11-05 10:54 john Note Added: 0000031
2005-11-08 12:21 john Relationship added related to 0000129
2005-11-29 07:57 john Note Added: 0000051
2006-01-04 10:11 john Relationship added related to 0000198
2006-01-04 10:15 john Note Added: 0000219
2006-01-04 10:33 john Relationship added related to 0000199
2006-02-07 13:17 john Target release => 1.0
2006-02-07 13:22 john Target release 1.0 => 0.9.6
2006-05-10 02:27 john Status new => assigned
2006-05-10 02:27 john Assigned To => john
2006-05-10 02:29 john Status assigned => resolved
2006-05-10 02:29 john Resolution open => won't fix
2006-05-10 02:29 john Note Added: 0000324
2006-06-22 07:30 john Status resolved => closed
2006-06-22 07:30 john Note Added: 0000379