View Issue Details

IDProjectCategoryView StatusLast Update
0000402ascendinstaller-rpmpublic2011-02-22 17:34
Assigned Tojohn 
Status feedbackResolutionreopened 
Product Version0.9.6 
Target Version1.0Fixed in Version 
Summary0000402: python(abi) = 2.5 is needed by package ascend-0.9.6-0.f9.i386 (/home/daacosta/Download/ascend-0.9.6-0.f9.i386.rpm)
DescriptionI clean-installed Fedora 11 and tried to install ascend using the very latest rpm but got the error message on the summary:

python(abi) = 2.5 is needed by package ascend-0.9.6-0.f9.i386 (/home/daacosta/Download/ascend-0.9.6-0.f9.i386.rpm)

I tried to install python 2.5 but wasn't able to.

My question is:

Is it possible to build an RPM for ascend that's noarch?

regards and thanks,

TagsNo tags attached.


related to 0000403 closedjohn Error from SWIG with versions 1.3.39, 1.3.40 



2009-06-16 14:54

administrator   ~0000561

Hi Diego

I think that you should be able to compile ASCEND against Python 2.6, it's just a question of patching the .spec file. We already regularly compile against 2.6 on Ubuntu, but I'm not a daily Fedora user any more, so I haven't tried it on that distro.

It's not possible to build an RPM for ASCEND that's noarch, because it has binary dependency on libpython, due to the SWIG wrapper for libascend.

I guess that the fix for this bug is to add some conditional statements in the .spec file that change the Python version dependency for F11 to 2.6.


2009-06-16 19:40

administrator   ~0000562

Diego, I reread your message and I realise that I missed the point. Yes, using the Fedora 9 RPM is likely to give you errors; in this particular case, if you can provide Python 2.5 that will fix it. As far as I can tell, Fedora only provides a single version of Python so you're stuck -- you have to compile from source.

I tried this on a clean Fedora 11 virtual machine, and I get some errors on this distro. Looks like some SWIG-related bugs. I'll report this as a new bug, then report your bug resolved (there is nothing wrong with the .spec file).


2010-07-04 09:07

reporter   ~0000650

Hello John,

It's me again... I managed to build ascend using scons without errors. Currently there is an ascend folder on my home folder and I believe that I should be able to use ascend by simply typing 'ascend' on a terminal (tried that as root as well and tried ascend4... cd'ed to the ascend folder...) The output of this was:

[daacosta@escobero ~]$ ascend
Command not found.

What am I doing wrong? I used the following steps:

yum install scons subversion tk-devel flex bison gcc-gfortran gcc-c++ python-devel sundials-devel graphviz-devel swig
svn co svn:// [^] ascend
cd ascend

from bug report 0000403

I appreciate your time and thank you,


Issue History

Date Modified Username Field Change
2009-06-16 12:32 daacosta New Issue
2009-06-16 12:32 daacosta Status new => assigned
2009-06-16 12:32 daacosta Assigned To => john
2009-06-16 14:54 john Note Added: 0000561
2009-06-16 19:40 john Note Added: 0000562
2009-06-16 19:41 john Status assigned => resolved
2009-06-16 19:41 john Resolution open => fixed
2009-06-16 19:43 john Relationship added related to 0000403
2010-07-04 09:07 daacosta Note Added: 0000650
2010-07-04 09:07 daacosta Status resolved => feedback
2010-07-04 09:07 daacosta Resolution fixed => reopened
2011-02-22 17:34 john Target Version => 1.0