View Issue Details

IDProjectCategoryView StatusLast Update
0000444ascendpygtk guipublic2010-03-30 11:09
Reporterjohn 
Assigned Tojohn 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionduplicate 
Product Version0.9.7 
Target Version0.9.8Fixed in Version0.9.8 
Summary0000444: Error when 'check' clicked but no model open
DescriptionReported by Vikram Venkatesan:

Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/ascend/gtkbrowser.py", line 1085, check_click(self=<gtkbrowser.Browser instance at 0xb71de96c>, *args=(<gtk.ToolButton object at 0xa678a2c (GtkToolButton at 0xa71d920)>,))
      def check_click(self,*args):
        self.do_check()
        #self.reporter.reportError("CHECK clicked")
  variables: {'self.do_check': ('local', <bound method Browser.do_check of <gtkbrowser.Browser instance at 0xb71de96c>>)}
  File "/usr/lib/python2.6/dist-packages/ascend/gtkbrowser.py", line 721, do_check(self=<gtkbrowser.Browser instance at 0xb71de96c>)
        try:
          self.sim.build()
        except RuntimeError,e:
AttributeError: 'NoneType' object has no attribute 'build'
TagsNo tags attached.

Relationships

duplicate of 0000437 resolvedjohn attempt to check in the absence of any simulation object 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2010-03-30 11:05 john New Issue
2010-03-30 11:06 john Target Version => 0.9.8
2010-03-30 11:09 john Relationship added duplicate of 0000437
2010-03-30 11:09 john Duplicate ID 0 => 437
2010-03-30 11:09 john Status new => resolved
2010-03-30 11:09 john Fixed in Version => 0.9.8
2010-03-30 11:09 john Resolution open => duplicate
2010-03-30 11:09 john Assigned To => john